IE7 Sunset Coming August 2012

As mentioned previously, we’re in the process of refreshing the QuickBase UI code and the look and feel of our product to make your experience more modern, consistent, and easy to use. Old, out-of-date browsers like Internet Explorer 7 (IE7) don’t support the new capabilities that we need in order to deliver these improvements. So rather than compromise the new experience by accommodating archaic browsers like IE7, which is used by less than 5% of our customers, we’ve made the decision to only support modern browsers.

In our next major release, targeted for August 19th , we will discontinue support for IE7. This means that some current features, and most new features, may not work properly in that browser after that date.  Please see 8/21/2012 update below for new information.

We don’t want this discontinuation to be a surprise for folks. So starting with our release on June 10th we’ll show a dismissible message to all IE7 users when they access the My QuickBase page or an app dashboard announcing the discontinuation plan and encouraging them to upgrade their browser.

We’re encouraging all users, and especially app developers, to consider upgrading to Chrome or Firefox where possible, because in our tests these programs currently have the best performance when handling pages with large amounts of data – something that QuickBase often calls upon a browser to do.

We’re aware it might be a burden for some organizations to upgrade all their users by the August date. We will be assessing what the impacts may be for those who are still on IE7 in August and reaching out individually. But please be assured that this was not a decision we made lightly; it is necessary to move forward with QuickBase.

Update 8/21/2012:

As an interim solution while customers seek migration from IE7 to a more modern browser, we will add support of IE7 with Google Chrome Frame Plug-in. This widely-used Plug-in for Microsoft Internet Explorer is being used by large sites such as Salesforce.com, Gmail, Yahoo, Cnet, Groupon, WordPress and others. This plug-in allows IE7 to render the latest browser features. Intuit’s support of the IE7 Plug-in with QuickBase will enable IE7 users to temporarily continue to use their QuickBase apps until they finish their migration to newer supported browsers.

Note that the Plug-in won’t affect other sites that rely on IE7. Also, users won’t need admin privileges to activate the plug-in.

Beginning on August 29, 2012, users accessing QuickBase via IE7 will see a banner message on the top of their pages urging them to upgrade, switch browsers, or activate the Google Chrome Frame Plug-in.

Starting on September 13, 2012, users won’t be able to access QuickBase via IE7 until they activate the plug-in or upgrade their browser.  We recommend that IE7 users who know they will not able to upgrade install the plug-in in advance of the Sept 13 deadline, here: http://www.google.com/chromeframe/

Ellie Ellerman

I’m a product manager at Intuit QuickBase in Waltham, MA. I like biking to work, British mysteries, and sci-fi action movies.

More Posts

  • Jose Rayos

    What happens if we cannot upgrade our browser and IE7 is our only option?  Will need to cancel my subscription and find a new platform for my application?

    [Reply]

  • Ellie Ellerman

    Please see the updated information about our support for
    Google Chrome Frame Plug-in for IE7. In summary, until further notice IE7 users will be able
    to continue to access QuickBase after the sunset date as long as they have
    activated the Plug-in.

    [Reply]

  • Jose Rayos

    Are there any release notes for the new update? I have heard from my account rep that there may new functionality, I just wantedto get an idea of what it may be. Also, are there any concerns with existing applications working in the new environment?

    [Reply]